Forums: Not sending emails - Forums

Jump to content

Page 1 of 1
  • You cannot start a new topic
  • You cannot reply to this topic

Not sending emails Emails not sending and receiving no errors Rate Topic: -----

#1 User is offline   smcrutchfield 

  • Member
  • PipPip
  • Group: Members
  • Posts: 26
  • Joined: 09-June 16
  • Gender:Female

Posted 13 May 2019 - 06:22 PM

I have a Work Order table with a view table Request Table which adds the record to the Work Order table. I have tried putting the following in After and Before Record Added in both the View table and the Work Order table. If you add a Work Order via the Request View Table, the work order is created, however no email is sent nor error received. If you create a work order from the work order table it is set to open in edit at this point the screen goes blank and you have to close the tab or resubmit it the request. The record is added to the database.

I need to email the company owner when a new work order is added. I will also need to email the customer when the work order is updated. Any help on what the issue is in the code below is greatly appreciated.


/********** Send email with new data ************
$email = "akronmiller@pmsindy.com";
$from = "crutch0316@gmail.com";
$subject = "Test New Request Added";
$message = "New Request - TEST"."\r\n";
$message = "Name: ".$values["contact]"]."\r\n";
$message = "Request: ".$values["request]"]."\r\n";
$message = "Priority: ".$values["priority]"]."\r\n";
$arr = runner_mail(array('to' => $email, 'subject' => $subject, 'body' => $message, 'from' => $from));

//if error happened print a message on the web page
if (!$arr["mailed"]) {
echo "Error happened: <br>";
echo "File: " . $arr["errors"][0]["file"] . "<br>";
echo "Line: " . $arr["errors"][0]["line"] . "<br>";
echo "Description: " . $arr["errors"][0]["description"] . "<br>";
}

I originally had set up with the company email, however followed the email setup provided for gmail to continue to test.

Unable to attach image, the Email settings are below

from email: crutch0316@gmail.com
smtp.gmail.com
465 - SSL
crutch0316@gmail.com
Correct Password

Thanks,

Sandy
0

#2 User is offline   admin 

  • Administrator
  • PipPipPip
  • Group: Admin
  • Posts: 16358
  • Joined: 03-February 03
  • Gender:Male

Posted 13 May 2019 - 09:07 PM

Make sure that two-factor authentication is turned off in Gmail settings.
Best regards,
Sergey Kornilov
0

Page 1 of 1
  • You cannot start a new topic
  • You cannot reply to this topic

1 User(s) are reading this topic
0 members, 1 guests, 0 anonymous users