Forums: Calendar Template Global Settings - Forums

Jump to content

Page 1 of 1
  • You cannot start a new topic
  • This topic is locked

Calendar Template Global Settings ver. 2.0

#1 User is offline   Sergej 

  • Advanced Member
  • PipPipPip
  • Group: Members
  • Posts: 111
  • Joined: 09-December 11

Posted 14 June 2015 - 08:24 PM

Global settings in Calendar template not remembered - on every new page load the settings are not applied - although they are kept in the settings table - it is necessary to edit some data there end then the whole settings is again applied. - By this settings i mean Mon- Sunday Week - collor for weekends and holidays and such - anyone else had the same problems...
0

#2 User is offline   admin 

  • Administrator
  • PipPipPip
  • Group: Admin
  • Posts: 16053
  • Joined: 03-February 03

Posted 15 June 2015 - 12:54 PM

You probably need to logout and login again after making changes to Global settings.
Best regards,
Sergey Kornilov
0

#3 User is offline   Sergej 

  • Advanced Member
  • PipPipPip
  • Group: Members
  • Posts: 111
  • Joined: 09-December 11

Posted 15 June 2015 - 04:57 PM

Hi, Sergey,
no it is not the case - even after logging out/in it turns back with old values - week - Sun - Saturday, not Monday - Sunday - no colours, no tekst displayed , just more link?
0

#4 User is offline   admin 

  • Administrator
  • PipPipPip
  • Group: Admin
  • Posts: 16053
  • Joined: 03-February 03

Posted 15 June 2015 - 08:21 PM

Something must be wrong here. If you need more help post your project to Demo Account supplying URL and instructions on reproducing the issue.
Best regards,
Sergey Kornilov
0

#5 User is offline   Sergej 

  • Advanced Member
  • PipPipPip
  • Group: Members
  • Posts: 111
  • Joined: 09-December 11

Posted 16 June 2015 - 06:54 AM

View Postadmin, on 15 June 2015 - 09:21 PM, said:

Something must be wrong here. If you need more help post your project to Demo Account supplying URL and instructions on reproducing the issue.

Dear Sergey,
here is the link from demo account:
demo link
Global settings for calendar not being remembered on the calendar's year, month and weekly list page, although they are correct in the settings table. After going to edit the settings table - no changes necessary - and returning to year, month and weekly list pages everything is ok, until the logout is made or until the pages in explorer closed. After new opening / log in - the whole process must be repeated again.
0

#6 User is offline   taumic 

  • Advanced Member
  • PipPipPip
  • Group: Members
  • Posts: 86
  • Joined: 18-November 08

Posted 20 July 2015 - 10:57 AM

Hello Sergej,


I have exactly the same problems with the calendar as you.
Have you found a solution?

Thanks

Michael
0

#7 User is offline   taumic 

  • Advanced Member
  • PipPipPip
  • Group: Members
  • Posts: 86
  • Joined: 18-November 08

Posted 21 July 2015 - 01:06 PM

Hello Sergej,

maybe I have a solution for you.
Try to put this request in "Events - LoginPage - After successful login"

CALENDAR_GETGLOBALSETTINGS()

I put this request in my local project and voila - it runs .

Greetings

Michael
0

#8 User is offline   admin 

  • Administrator
  • PipPipPip
  • Group: Admin
  • Posts: 16053
  • Joined: 03-February 03

Posted 21 July 2015 - 01:43 PM

Sergej had an issue where Calendar template was added to another project. To fix this we had to add code from Calendar's project AfterAppInit event to that existing project AfterAppInit event.
Best regards,
Sergey Kornilov
0

Page 1 of 1
  • You cannot start a new topic
  • This topic is locked